Plugin’s descriptor contains the wrong version: 12.2.1-1-0

If you have the message while building SOA 12c with Maven. ” Invalid plugin descriptor for com.oracle.soa.plugin:oracle-soa-plugin:12.2.1-2-0 (/data/appdata/.m12c/repository/com/oracle/soa/plugin/oracle-soa-plugin/12.2.1-2-0/oracle-soa-plugin-12.2.1-2-0.jar), Plugin’s descriptor contains the wrong version: 12.2.1-1-0 ->” you need to update the configuration files inside the JAR file in “oracle-soa-plugin-12.2.1-2-0.jar“. Edit the jar file with 7zip and go to “META-INF\maven\’ edit plugin.xml and replace 12.2.1-1-0 with 12.2.1-2-0. you […]

Continue reading